Using Alsa, Jack, Dttsp with Linux

Terry Fox tfox at
Wed Oct 24 15:04:41 CDT 2007

Mel (W4MEL) and I have been messing with SDRs for a while now.  Mel has
modified Edson's sdr-shell program to include DDS control, and we were
working to add transmit capability to it.  but, we've run into a stumbling

Jack allows only one sound card to be used at a time.  We want to be able to
use two sound cards (one low-end for audio in & out, and a better one for
the IF signals in/out from the dttsp core) to get four channels of ins &
outs.  This is since most economical (read: under $200) sound cards only
have two channel inputs for capture.  Even cards that claim to have both mic
and line, in reality have only one stereo input, with either a preamp or
fixed attenuator.  We need:

Built-in sound card:
1 or 2 mediocre input channels for mic/line into dttsp for modulation
2 mediocre output channels for dttsp audio out to speakers
Better sound card:
2 decent input channels for SDR IF input to dttsp from hardware
2 decent output channels for SDR IF output from dttsp to hardware

So, we found a method of creating a "virtual" sound card under Alsa, that
allows the tying of two physical sound cards into a single virtual card.  We
were also pointed to the same method by the dttsp gurus.  It "gangs" the
individual actual sound card resources into one virtual sound card that jack
then sees as a single device.

Unfortunately, it doesn't work.  Mel has tried many, many times to edit the
Alsa config files to match various recommendations (see the Alsa wiki, etc),
but it will not work.  Even though others claim that their configurations
function OK, when we try them, they don't work.

We found out that Alsa had a problem with this being broken until rev 4 (I
think), and Rev 4 has it fixed, but we have tried Rev 4 without luck.

So, has anyone out there in Tacoland played enough with Alsa, jack, etc
under Linux that they may be knowledgeable and help us out?  We are stuck at
this point where we are SO close to transmitting with SDR under Ubuntu
Linux, but cannot get past this issue.


More information about the Tacos mailing list